Pages

Tuesday, July 25, 2006

Default python version in Debian

這件事困擾我很久了,Debian  一直不把預設的  python  version  改到  2.4 雖然目前  2.3  2.4  都有,但有些套件還是相依於  2.3,要拿又拿不掉  :(

mail  list  上也有人抱怨這件事,但大概只能自己安裝  module  來解決了

Re-setting  Debian  default  python  version  [Link] How  can  I  change  Debian's  default  Python  version?  [Link]

不久前在  LWN.net  上也提過這件事 Debian  Python  packages  in  sid  [Link]

看起來要靠官方機制的話,一時半刻還等不到...

來看看把  python2.3  移除會變怎樣

#  apt-get  -s  --purge  remove  python2.3 [skip] Purg  gazpacho  [0.6.5-2] Purg  libglade2-dev  [1:2.5.1-2] Purg  python-gtk2  [2.8.6-3] Purg  python-support  [0.3.8] Purg  python-pyx  [0.9-2] Purg  python-numeric  [24.2-5] Purg  python2.4-pysqlite2  [2.2.2-1] Purg  python2.4-pexpect  [2.0-2] Purg  python2.4  [2.4.3-7] Purg  python2.4-minimal  [2.4.3-7] Purg  python-cairo  [1.2.0-1] Purg  python-central  [0.5.1]  [python2.3  ] Purg  python  [2.3.5-11]  [python2.3  ] Purg  python2.3  [2.3.5-14]

看吧,真是可怕的東西....竟然想移除所有  python  相關套件 我對於  Debian  這種自作聰明的做法一直很感冒,但這功能好像蠻受歡迎的@@ 很多人厭惡  Windxxz  的  *貼心*,卻能容忍  apt  的雞婆? 也許趕快弄出一個  slackware  版本的  colinux  image  才是長久之計XD

Debian  Python  FAQ  [Link] Debian  Python  Policy  [Link] New  Policy  [Link]


This article was originally posted on this site.

No comments:

Post a Comment